Current version (0.17) is terribly outdated, please update nim compiler to 0.19